$re = '/^ip=(.*)$/m';
$str = 'fl=4f422
h=www.cloudflare.com
ip=54.193.27.106
ts=1575967108.245';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);