// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^ip=(.*)$").unwrap();
let string = "fl=4f422
h=www.cloudflare.com
ip=54.193.27.106
ts=1575967108.245";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}