using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?'phpvar'[a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*):([-+]?(?'expr'(\g<phpvar>|\d+(\.\d+)?|[-+]?\(\g<expr>\))([-+*\/]\g<expr>)?)))+(;\g<1>)*$";
string input = @"header1:(a1+a2)*(a3-a1);header2:b1*(b2-b3)/b4;header3:c1*(c2);header4:((a1*(a2-b1))/(a3-a1))+b2";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}