// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^((?'phpvar'[a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*):([-+]?(?'expr'(\g<phpvar>|\d+(\.\d+)?|[-+]?\(\g<expr>\))([-+*\/]\g<expr>)?)))+(;\g<1>)*$").unwrap();
let string = "header1:(a1+a2)*(a3-a1);header2:b1*(b2-b3)/b4;header3:c1*(c2);header4:((a1*(a2-b1))/(a3-a1))+b2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}