package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((?'phpvar'[a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*):([-+]?(?'expr'(\g<phpvar>|\d+(\.\d+)?|[-+]?\(\g<expr>\))([-+*\/]\g<expr>)?)))+(;\g<1>)*$`)
var str = `header1:(a1+a2)*(a3-a1);header2:b1*(b2-b3)/b4;header3:c1*(c2);header4:((a1*(a2-b1))/(a3-a1))+b2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}