const regex = /^((?'phpvar'[a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*):([-+]?(?'expr'(\g<phpvar>|\d+(\.\d+)?|[-+]?\(\g<expr>\))([-+*\/]\g<expr>)?)))+(;\g<1>)*$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?\'phpvar\'[a-zA-Z_\\x7f-\\xff][a-zA-Z0-9_\\x7f-\\xff]*):([-+]?(?\'expr\'(\\g<phpvar>|\\d+(\\.\\d+)?|[-+]?\\(\\g<expr>\\))([-+*\\\/]\\g<expr>)?)))+(;\\g<1>)*$', 'g')
const str = `header1:(a1+a2)*(a3-a1);header2:b1*(b2-b3)/b4;header3:c1*(c2);header4:((a1*(a2-b1))/(a3-a1))+b2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}