use strict;
my $str = 'header1:(a1+a2)*(a3-a1);header2:b1*(b2-b3)/b4;header3:c1*(c2);header4:((a1*(a2-b1))/(a3-a1))+b2';
my $regex = qr/^((?'phpvar'[a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*):([-+]?(?'expr'(\g<phpvar>|\d+(\.\d+)?|[-+]?\(\g<expr>\))([-+*\/]\g<expr>)?)))+(;\g<1>)*$/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}