#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=#{1,6} (.*)\n(?:(?!#).*\n)*)(?=[+*-] (.*(?:\n(?![#+*-]).*)?))"
Local $sString = "# Test" & @CRLF & _
"" & @CRLF & _
"## First List" & @CRLF & _
"" & @CRLF & _
"* Hello World" & @CRLF & _
"* Lorem" & @CRLF & _
"* foo" & @CRLF & _
"" & @CRLF & _
"## Second List" & @CRLF & _
"" & @CRLF & _
"- item" & @CRLF & _
"" & @CRLF & _
"## Third List" & @CRLF & _
"" & @CRLF & _
"+ item 1" & @CRLF & _
"part of item 1" & @CRLF & _
"+ item 2" & @CRLF & _
"" & @CRLF & _
"## Not a List" & @CRLF & _
"" & @CRLF & _
"bla bla bla" & @CRLF & _
"" & @CRLF & _
"## Empty" & @CRLF & _
"" & @CRLF & _
"## Another List" & @CRLF & _
"" & @CRLF & _
"bla bla bla" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"bla" & @CRLF & _
"" & @CRLF & _
"* ITEM" & @CRLF & _
"" & @CRLF & _
"## Nested List" & @CRLF & _
"" & @CRLF & _
"### Inside Nested" & @CRLF & _
"" & @CRLF & _
"* foo" & @CRLF & _
"* bar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")