# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=#{1,6} (.*)\n(?:(?!#).*\n)*)(?=[+*-] (.*(?:\n(?![#+*-]).*)?))"
test_str = ("# Test\n\n"
"## First List\n\n"
"* Hello World\n"
"* Lorem\n"
"* foo\n\n"
"## Second List\n\n"
"- item\n\n"
"## Third List\n\n"
"+ item 1\n"
"part of item 1\n"
"+ item 2\n\n"
"## Not a List\n\n"
"bla bla bla\n\n"
"## Empty\n\n"
"## Another List\n\n"
"bla bla bla\n\n\n\n"
"bla\n\n"
"* ITEM\n\n"
"## Nested List\n\n"
"### Inside Nested\n\n"
"* foo\n"
"* bar")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.