import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=#{1,6} (.*)\\n(?:(?!#).*\\n)*)(?=[+*-] (.*(?:\\n(?![#+*-]).*)?))";
final String string = "# Test\n\n"
+ "## First List\n\n"
+ "* Hello World\n"
+ "* Lorem\n"
+ "* foo\n\n"
+ "## Second List\n\n"
+ "- item\n\n"
+ "## Third List\n\n"
+ "+ item 1\n"
+ "part of item 1\n"
+ "+ item 2\n\n"
+ "## Not a List\n\n"
+ "bla bla bla\n\n"
+ "## Empty\n\n"
+ "## Another List\n\n"
+ "bla bla bla\n\n\n\n"
+ "bla\n\n"
+ "* ITEM\n\n"
+ "## Nested List\n\n"
+ "### Inside Nested\n\n"
+ "* foo\n"
+ "* bar";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}