re = /(?<=#{1,6} (.*)\n(?:(?!#).*\n)*)(?=[+*-] (.*(?:\n(?![#+*-]).*)?))/
str = '# Test
## First List
* Hello World
* Lorem
* foo
## Second List
- item
## Third List
+ item 1
part of item 1
+ item 2
## Not a List
bla bla bla
## Empty
## Another List
bla bla bla
bla
* ITEM
## Nested List
### Inside Nested
* foo
* bar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end