import Foundation
let pattern = ##"(?<=#{1,6} (.*)\n(?:(?!#).*\n)*)(?=[+*-] (.*(?:\n(?![#+*-]).*)?))"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ####"""
# Test
## First List
* Hello World
* Lorem
* foo
## Second List
- item
## Third List
+ item 1
part of item 1
+ item 2
## Not a List
bla bla bla
## Empty
## Another List
bla bla bla
bla
* ITEM
## Nested List
### Inside Nested
* foo
* bar
"""####
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)