using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\index(\{((?:[^{}]+|(?1))+)\})";
string input = @"Sentence \index{Palenque} with two LaTeX index entries \index{Yaxchilan!Itzamnaah B'ahlam@\textit{Itzamnaah B'ahlam}!warfare} in it.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}