package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\\index(\{((?:[^{}]+|(?1))+)\})`)
var str = `Sentence \index{Palenque} with two LaTeX index entries \index{Yaxchilan!Itzamnaah B'ahlam@\textit{Itzamnaah B'ahlam}!warfare} in it.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}