const regex = new RegExp('\\\\index(\\{((?:[^{}]+|(?1))+)\\})', 'gm')
const str = `Sentence \\index{Palenque} with two LaTeX index entries \\index{Yaxchilan!Itzamnaah B'ahlam@\\textit{Itzamnaah B'ahlam}!warfare} in it.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}