re = /\\index(\{((?:[^{}]+|(?1))+)\})/m
str = 'Sentence \\index{Palenque} with two LaTeX index entries \\index{Yaxchilan!Itzamnaah B\'ahlam@\\textit{Itzamnaah B\'ahlam}!warfare} in it.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end