import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*\\strig:[01]\\s.*";
final String string = "id:61Xxx9X3c-X095-Xb92-82fd-54bXX2XXc trig:3 date:1612330983 lat:XX.75XX1909XXX3XX long:X.XXX9XXXX5XXXXX dev:61Xxx9X3c-X095-Xb92-82fd-54bXX2XXc devAlias=-";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}