// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*\strig:[01]\s.*").unwrap();
let string = "id:61Xxx9X3c-X095-Xb92-82fd-54bXX2XXc trig:3 date:1612330983 lat:XX.75XX1909XXX3XX long:X.XXX9XXXX5XXXXX dev:61Xxx9X3c-X095-Xb92-82fd-54bXX2XXc devAlias=-";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}