re = /.*\strig:[01]\s.*/m
str = 'id:61Xxx9X3c-X095-Xb92-82fd-54bXX2XXc trig:3 date:1612330983 lat:XX.75XX1909XXX3XX long:X.XXX9XXXX5XXXXX dev:61Xxx9X3c-X095-Xb92-82fd-54bXX2XXc devAlias=-'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end