const regex = /.*\strig:[01]\s.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\strig:[01]\\s.*', 'gm')
const str = `id:61Xxx9X3c-X095-Xb92-82fd-54bXX2XXc trig:3 date:1612330983 lat:XX.75XX1909XXX3XX long:X.XXX9XXXX5XXXXX dev:61Xxx9X3c-X095-Xb92-82fd-54bXX2XXc devAlias=-`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}