using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?):(.*?)(?:$|(,)(?=\w+:))";
string substitution = @"""\1"" : ""\2""\3\r\n";
string input = @"Street:StreetName,Address:ABC Road, CityName,PinCode:00000";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}