$re = '/(.*?):(.*?)(?:$|(,)(?=\w+:))/m';
$str = 'Street:StreetName,Address:ABC Road, CityName,PinCode:00000';
$subst = "\"\1\" : \"\2\"\3\r\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;