const regex = new RegExp('(.*?):(.*?)(?:$|(,)(?=\\w+:))', 'gm')
const str = `Street:StreetName,Address:ABC Road, CityName,PinCode:00000`;
const subst = `"\1" : "\2"\3\r\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);