import re
regex = re.compile(r"(.*?):(.*?)(?:$|(,)(?=\w+:))", flags=re.MULTILINE)
test_str = "Street:StreetName,Address:ABC Road, CityName,PinCode:00000"
subst = "\"\\1\" : \"\\2\"\\3\\r\\n"
result = regex.sub(subst, test_str)
if result:
print(result)