re = /(.*?):(.*?)(?:$|(,)(?=\w+:))/m
str = 'Street:StreetName,Address:ABC Road, CityName,PinCode:00000'
subst = '"\\1" : "\\2"\\3\\r\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result