#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(.*\:\s)(.*)(\:)(.*)"
Local $sString = "Beispieltext: Übermenschliche Titel: Mit Umlauten"
Local $sSubst = "\2 -\4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)