using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*\:\s)(.*)(\:)(.*)";
string substitution = @"\2 -\4";
string input = @"Beispieltext: Übermenschliche Titel: Mit Umlauten";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}