const regex = /(.*\:\s)(.*)(\:)(.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*\\:\\s)(.*)(\\:)(.*)', 'g')
const str = `Beispieltext: Übermenschliche Titel: Mit Umlauten`;
const subst = `\2 -\4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);