$re = '/(.*\:\s)(.*)(\:)(.*)/';
$str = 'Beispieltext: Übermenschliche Titel: Mit Umlauten';
$subst = "\2 -\4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;