import re
regex = re.compile(r"(.*\:\s)(.*)(\:)(.*)")
test_str = "Beispieltext: Übermenschliche Titel: Mit Umlauten"
subst = "\\2 -\\4"
result = regex.sub(subst, test_str)
if result:
print(result)