#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((\<soafault:faultDescription\>)|(\"faultDescription\"\s*:\s*\"))(?<faultDescription>[^\"\<]+)"
Local $sString = ""faultDescription" : "Backend system error has occurred."," & @CRLF & _
"<soafault:faultDescription>SKU is not provided</soafault:faultDescription>" & @CRLF & _
"<soafault:faultDescription>SKU is not provided</soafault:faultDescription>" & @CRLF & _
""faultDescription":"No results found for the given ICCID.""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")