package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((\<soafault:faultDescription\>)|(\"faultDescription\"\s*:\s*\"))(?<faultDescription>[^\"\<]+)`)
var str = `"faultDescription" : "Backend system error has occurred.",
<soafault:faultDescription>SKU is not provided</soafault:faultDescription>
<soafault:faultDescription>SKU is not provided</soafault:faultDescription>
"faultDescription":"No results found for the given ICCID."`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}