import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((\\<soafault:faultDescription\\>)|(\\\"faultDescription\\\"\\s*:\\s*\\\"))(?<faultDescription>[^\\\"\\<]+)";
final String string = "\"faultDescription\" : \"Backend system error has occurred.\",\n"
+ "<soafault:faultDescription>SKU is not provided</soafault:faultDescription>\n"
+ "<soafault:faultDescription>SKU is not provided</soafault:faultDescription>\n"
+ "\"faultDescription\":\"No results found for the given ICCID.\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}