import re
regex = re.compile(r"^((\<soafault:faultDescription\>)|(\"faultDescription\"\s*:\s*\"))(?<faultDescription>[^\"\<]+)", flags=re.MULTILINE)
test_str = ("\"faultDescription\" : \"Backend system error has occurred.\",\n"
"<soafault:faultDescription>SKU is not provided</soafault:faultDescription>\n"
"<soafault:faultDescription>SKU is not provided</soafault:faultDescription>\n"
"\"faultDescription\":\"No results found for the given ICCID.\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")