// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^((\<soafault:faultDescription\>)|(\"faultDescription\"\s*:\s*\"))(?<faultDescription>[^\"\<]+)"#).unwrap();
let string = "\"faultDescription\" : \"Backend system error has occurred.\",
<soafault:faultDescription>SKU is not provided</soafault:faultDescription>
<soafault:faultDescription>SKU is not provided</soafault:faultDescription>
\"faultDescription\":\"No results found for the given ICCID.\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}