using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((\<soafault:faultDescription\>)|(\""faultDescription\""\s*:\s*\"")|(\<faultDescription\>))(?<faultDescription>[^\""\<]+)";
string input = @"<soafault:faultDescription>SKU is not provided</soafault:faultDescription>
""faultDescription"" : ""Backend system error has occurred.""
<faultDescription>Backend system error has occurred.</faultDescription>
""faultDescription"":""No results found for the given ICCID.""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}