$re = '/^((\<soafault:faultDescription\>)|(\"faultDescription\"\s*:\s*\")|(\<faultDescription\>))(?<faultDescription>[^\"\<]+)/m';
$str = '<soafault:faultDescription>SKU is not provided</soafault:faultDescription>
"faultDescription" : "Backend system error has occurred."
<faultDescription>Backend system error has occurred.</faultDescription>
"faultDescription":"No results found for the given ICCID."';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);