re = /^((\<soafault:faultDescription\>)|(\"faultDescription\"\s*:\s*\")|(\<faultDescription\>))(?<faultDescription>[^\"\<]+)/m
str = '<soafault:faultDescription>SKU is not provided</soafault:faultDescription>
"faultDescription" : "Backend system error has occurred."
<faultDescription>Backend system error has occurred.</faultDescription>
"faultDescription":"No results found for the given ICCID."'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end