use strict;
my $str = '<soafault:faultDescription>SKU is not provided</soafault:faultDescription>
"faultDescription" : "Backend system error has occurred."
<faultDescription>Backend system error has occurred.</faultDescription>
"faultDescription":"No results found for the given ICCID."';
my $regex = qr/^((\<soafault:faultDescription\>)|(\"faultDescription\"\s*:\s*\")|(\<faultDescription\>))(?<faultDescription>[^\"\<]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}