const regex = /^((\<soafault:faultDescription\>)|(\"faultDescription\"\s*:\s*\")|(\<faultDescription\>))(?<faultDescription>[^\"\<]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((\\<soafault:faultDescription\\>)|(\\"faultDescription\\"\\s*:\\s*\\")|(\\<faultDescription\\>))(?<faultDescription>[^\\"\\<]+)', 'gm')
const str = `<soafault:faultDescription>SKU is not provided</soafault:faultDescription>
"faultDescription" : "Backend system error has occurred."
<faultDescription>Backend system error has occurred.</faultDescription>
"faultDescription":"No results found for the given ICCID."`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}