import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*businessDate\\=([^\\\\]*)\\\\u0026closeoutSchemeId\\=([^\\\\]*)\\\\u0026.*positionStateId\\=([^\\\"]*)";
final String string = "{\"StatusCode\":204,\"ReasonPhrase\":\"No Content\",\"Method\":\"GET\",\"PathAndQuery\":\"/api/ibor/v2/positionValuations?businessDate=2017-09-04\\u0026closeoutSchemeId=1\\u0026expand=*\\u0026logicalTimeId=150\\u0026positionStateId=40\",\"MessageType\":\"Response\"}\n\n"
+ "{\"Method\":\"GET\",\"PathAndQuery\":\"/api/ibor/v2/positionValuations?businessDate=2017-09-04\\u0026closeoutSchemeId=1\\u0026expand=*\\u0026logicalTimeId=150\\u0026positionStateId=40\",\"MessageType\":\"Request\"}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}