re = /.*businessDate\=([^\\]*)\\u0026closeoutSchemeId\=([^\\]*)\\u0026.*positionStateId\=([^\"]*)/
str = '{"StatusCode":204,"ReasonPhrase":"No Content","Method":"GET","PathAndQuery":"/api/ibor/v2/positionValuations?businessDate=2017-09-04\\u0026closeoutSchemeId=1\\u0026expand=*\\u0026logicalTimeId=150\\u0026positionStateId=40","MessageType":"Response"}
{"Method":"GET","PathAndQuery":"/api/ibor/v2/positionValuations?businessDate=2017-09-04\\u0026closeoutSchemeId=1\\u0026expand=*\\u0026logicalTimeId=150\\u0026positionStateId=40","MessageType":"Request"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end