use strict;
my $str = '{"StatusCode":204,"ReasonPhrase":"No Content","Method":"GET","PathAndQuery":"/api/ibor/v2/positionValuations?businessDate=2017-09-04\\u0026closeoutSchemeId=1\\u0026expand=*\\u0026logicalTimeId=150\\u0026positionStateId=40","MessageType":"Response"}
{"Method":"GET","PathAndQuery":"/api/ibor/v2/positionValuations?businessDate=2017-09-04\\u0026closeoutSchemeId=1\\u0026expand=*\\u0026logicalTimeId=150\\u0026positionStateId=40","MessageType":"Request"}';
my $regex = qr/.*businessDate\=([^\\]*)\\u0026closeoutSchemeId\=([^\\]*)\\u0026.*positionStateId\=([^\"]*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}