# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*businessDate\=([^\\]*)\\u0026closeoutSchemeId\=([^\\]*)\\u0026.*positionStateId\=([^\"]*)"
test_str = ("{\"StatusCode\":204,\"ReasonPhrase\":\"No Content\",\"Method\":\"GET\",\"PathAndQuery\":\"/api/ibor/v2/positionValuations?businessDate=2017-09-04\\u0026closeoutSchemeId=1\\u0026expand=*\\u0026logicalTimeId=150\\u0026positionStateId=40\",\"MessageType\":\"Response\"}\n\n"
"{\"Method\":\"GET\",\"PathAndQuery\":\"/api/ibor/v2/positionValuations?businessDate=2017-09-04\\u0026closeoutSchemeId=1\\u0026expand=*\\u0026logicalTimeId=150\\u0026positionStateId=40\",\"MessageType\":\"Request\"}")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.