// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#".*businessDate\=([^\\]*)\\u0026closeoutSchemeId\=([^\\]*)\\u0026.*positionStateId\=([^\"]*)"#).unwrap();
let string = "{\"StatusCode\":204,\"ReasonPhrase\":\"No Content\",\"Method\":\"GET\",\"PathAndQuery\":\"/api/ibor/v2/positionValuations?businessDate=2017-09-04\\u0026closeoutSchemeId=1\\u0026expand=*\\u0026logicalTimeId=150\\u0026positionStateId=40\",\"MessageType\":\"Response\"}
{\"Method\":\"GET\",\"PathAndQuery\":\"/api/ibor/v2/positionValuations?businessDate=2017-09-04\\u0026closeoutSchemeId=1\\u0026expand=*\\u0026logicalTimeId=150\\u0026positionStateId=40\",\"MessageType\":\"Request\"}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}