package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\b(?:county coast|at the|grants pass)\b(*SKIP)(*F)|\b(?:coast|the|pass)\b`)
var str = `at the coast will reach the Douglas County coast`
var substitution = "<b>$0</b>"
fmt.Println(re.ReplaceAllString(str, substitution))
}