use strict;
my $str = 'at the coast will reach the Douglas County coast';
my $regex = qr~\b(?:county coast|at the|grants pass)\b(*SKIP)(*F)|\b(?:coast|the|pass)\b~ip;
my $subst = '<b>$0</b>';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";