import Foundation
let pattern = #"\b(?:county coast|at the|grants pass)\b(*SKIP)(*F)|\b(?:coast|the|pass)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"at the coast will reach the Douglas County coast"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<b>$0</b>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)