import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:county coast|at the|grants pass)\\b(*SKIP)(*F)|\\b(?:coast|the|pass)\\b";
final String string = "at the coast will reach the Douglas County coast";
final String subst = "<b>$0</b>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}