$re = '~\b(?:county coast|at the|grants pass)\b(*SKIP)(*F)|\b(?:coast|the|pass)\b~i';
$str = 'at the coast will reach the Douglas County coast';
$subst = "<b>$0</b>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;